Logo du forum
 

Forum TTH-News

| Inscription | | Recherche | | FAQ | | Accueil | | Liste des membres |
| Calendrier |
 
Vous n'êtes pas identifié! [Connexion] ou [Inscription] Forum » Programmation » [HTML / CSS] » Souci avec des accents
Login Mot de passe

2 visiteurs sur ce topic (0 membre(s), 2 invité(s) )


Auteur
Sujet : Souci avec des accents
Paddy
Vétéran
Membre # 8375

 Avatar du membre
Lieu : Sélestat

Messages :
8550 (1.57 par jour)


Score :

Message du 23-10-2009 @ 18:25   Afficher le profil   Envoyer un message privé   Editer le message   Citer le message      Afficher l'adresse IP   Alerter les modérateurs   


Voila mon souci :
Dans une application web que je développe, j'ai dans une jsp 2 select, le contenu du second dépendant du contenu du premier.
Pour ensuite remplir ce select, j'ai un bout de js qui récupère une clé permettant de récupérer un label dans un fichier de properties.
Or, peu importe le code que j'inscris dans ce fichier de properties (é ou &ecute; par exemple), la sortie n'est jamais correcte (é devient é et &ecute; reste &ecute;)

Avez vous une idée pour solutionner mon problème ? J'ai l'impression que cela vient de mon js qui n'arrive pas à transmettre la bonne info.
----------
Masterdiablo /// PS3 - Wii U - iPhone 7s 256Go - iPhone 6s 128Go (pour Madame)
Core i5 7600K - Asus Prime Z270-A - 2*8Gb Corsair Vengeance - Asus GeForce DUAL-GTX1070-O8G - Samsung 850 Pro 256Go - WD Black 2To - Fractal Define R5 Black
- Haut de page -
Paddy
Vétéran
Membre # 8375

 Avatar du membre
Lieu : Sélestat

Messages :
8550 (1.57 par jour)


Score :

Message du 24-10-2009 @ 10:12   Afficher le profil   Envoyer un message privé   Editer le message   Citer le message      Afficher l'adresse IP   Alerter les modérateurs   

En mettant des codes sous forme \\u00e9 (pour le é), cela a finalement fonctionné :D
----------
Masterdiablo /// PS3 - Wii U - iPhone 7s 256Go - iPhone 6s 128Go (pour Madame)
Core i5 7600K - Asus Prime Z270-A - 2*8Gb Corsair Vengeance - Asus GeForce DUAL-GTX1070-O8G - Samsung 850 Pro 256Go - WD Black 2To - Fractal Define R5 Black
- Haut de page -
wTb
Vétéran
Membre # 7349

 Avatar du membre
Lieu : Paris

Messages :
5864 (1.06 par jour)


Score :

Message du 04-01-2010 @ 20:14   Afficher le profil   Envoyer un message privé   Editer le message   Citer le message      Afficher l'adresse IP   Alerter les modérateurs   

Il faut que tu utilises un header qui spécifie l'encodage des caractères (utf-8 ou iso-8859-1) grâce à une balise ou bien directement dans la config du projet de ton IDE ;)
----------
"Il n'existe que deux choses infinies, l'univers et la bêtise humaine... mais pour l'univers, je n'ai pas de certitude absolue."
Albert Einstein

Q9550@3.4Ghz, Asus P5E, 8Go DDR2 OCZ Reaper, Asus GTX580 OC, SSD Samsung 840Evo + Raptor 150go + 4To.
- Haut de page -


Aller dans le forum :  

Plan du forum | Contacter l'administrateur

Powered by SoulBB 3.0.1
© Soulmanto, 2003-2010

Valid XHTML 1.0 Transitional

Page générée en 0.032 secondes